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Introduction

Welcome to WebLOAD, the premier performance, scalability, and reliability testing
solution for internet applications.

WebLOAD is easy to use and delivers maximum testing performance and value.
WebLOAD verifies the scalability and integrity of internet applications by generating a
load composed of Virtual Clients that simulate real-world traffic. Probing Clients let
you refine the testing process by acting as a single user that measures the performance
of targeted activities, and provides individual performance statistics of the internet
application under load.

This section provides a brief introduction to WebLOAD technical support, including
both documentation and online support.

WebLOAD Documentation

WebLOAD is supplied with the following documentation:

WebLOAD™ Installation Guide
Instructions for installing WebLOAD and its add-ons.

WebLOAD™ IDE User’'s Guide

Instructions for recording, editing, and debugging load test Agendas to be
executed by WebLOAD to test your Web-based applications.

WebLOAD™ Console User’'s Guide

A guide to using WebLOAD console, RadView’s load/scalability testing tool to
easily and efficiently test your Web-based applications. This guide also includes a
quick start section containing instructions for getting started quickly with
WebLOAD using the RadView Software test site.

WEBLOAD 2?Installation Guide o] e
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WebLOAD™ Analytics User’s Guide

Instructions on how to use WebLOAD Analytics to analyze data and create
custom, informative reports after running a WebLOAD test session.

WebRM™ User’'s Guide

Instructions for managing testing resources with the WebLOAD Resource
Manager.

WebLOAD™ Scripting Guide

Complete information on scripting and editing JavaScript Agendas for use in
WebLOAD and WebLOAD IDE.

WebLOAD™ JavaScript Reference Guide

Complete reference information on all JavaScript objects, variables, and functions
used in WebLOAD and WebLOAD IDE test Agendas.

WebLOAD™ Extensibility SDK

Instructions on how to develop extensions to tailor WebLOAD to specific working
environments.

WebLOAD™ Automation Guide

Instructions for automatically running WebLOAD tests and reports from the
command line, or by using the WebLOAD plugin for Jenkins

WebLOAD™ Web Dashboard User Guide

Instructions for using RadView’s Web Dashboard to view, analyze and compare
load sessions in a web browser, with full control and customization of the display.

The guides are distributed with the WebLOAD software in online help format. The
guides are also supplied as Adobe Acrobat files. View and print these files using the
Adobe Acrobat Reader. Install the Reader from the Adobe website
http://www.adobe.com.

Chapter 1. Introduction
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Typographical Conventions

Before you start using this guide, it is important to understand the terms, icons, and
typographical conventions used in the documentation.

The following icons appear next to the text to identify special information.

Table 1: Icon Conventions

Icon Type of Information

@ Indicates a note.

@ Indicates a feature that is available
only as part of a WebLOAD Add-on.

The following kinds of formatting in the text identify special information.

Table 2: Typographical Conventions

Formatting Type of Information
convention

Special Bold Items you must select, such as menu options, command buttons,
or items in a list.

Emphasis Use to emphasize the importance of a point or for variable
expressions such as parameters.

CAPITALS Names of keys on the keyboard. for example, SHIFT, CTRL, or
ALT.
KEY+KEY Key combinations for which the user must press and hold down

one key and then press another, for example, CTRL+P or ALT+F4.

WEBLOAD 2?Installation Guide e 3
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Where to Get More Information

This section contains information on how to obtain technical support from RadView
worldwide, should you encounter any problems.

Online Help

WebLOAD provides a comprehensive on-line help system with step-by-step
instructions for common tasks.

You can press the F1 key on any open dialog box for an explanation of the options or
select Help » Contents to open the on-line help contents and index.

Technical Support Website
The technical support pages on our website contain:

* FAQ (Frequently Asked / Answered Questions).
* Agenda Center
* Documentation

* RadView’s Product Resource Center, where you can find prepared test scripts,
product information, and industry related news.

*  http://www.radview.com/support/index.asp

Technical Support

For technical support in your use of this product, contact:

North American Headquarters International Headquarters

e-mail: support@RadView.com e-mail: support@RadView.com

Phone: 1-888-RadView Phone: +972-3-915-7060
(1-888-723-8439) (Toll Free) Fax: +972-3-915-7683

908-526-7756
Fax: 908-864-8099

Note: We encourage you to use e-mail for faster and better service.

When contacting technical support please include in your message the full name of the
product, as well as the version and build number.

Chapter 1. Introduction
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WebLOAD has the following system requirements. WebLOAD Console, WebLOAD
IDE, WebLOAD Analytics, WebLOAD Probing Client, and WebRM can only be run on
Windows platforms. WebLOAD Load Machines can be run on Windows, and Linux

platforms.

N

which you are installing.

Note: For any installation, you must have Administrator rights for the computer on

Windows Platforms

Table 3: WebLOAD System Requirements

Requirements

WebLOAD Console, WebLOAD
IDE, WebLOAD Analytics,
WebLOAD Probing Client, and
WebRM

Load Machine

Computer / Processor

IBM-compatible PC (x86-32) with
Pentium I1I 800 MHz (or higher)
microprocessor

IBM-compatible PC (x86-32) with
Pentium III 800 MHz (or higher)
microprocessor; Pentium 4 is

recommended
Operating System * Windows 2000 Professional * Windows 2000 Server /
* Windows XP Pro (SP2) Advanced Server
e Windows Vista * Windows XP Pro (SP2)
e Windows 7 ®* Windows Vista
* Windows 8 * Windows7
e Windows Server 2003 * Windows Server 2003, Standard
and Enterprise Editions
* Wind S 2008
fndows server ®* Windows Server 2008
* Windows Server 2012
Memory 1 GB RAM (minimum); 4 GB is 1 GB RAM (minimum); 4 GB is
recommended recommended
Free Disk Space 2GB 2GB

WEBLOAD 2?Installation Guide
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Linux Platforms (for WebLOAD Load Machines)

Table 4: WebLOAD Load Machine System Requirements

Requirements Load Machine

Hardware IBM-compatible PC (x86-32) with Pentium III 800
MHz (or higher) microprocessor; Pentium 4 is
recommended

Version ® Fedora Core 3 or higher

® Red Hat Enterprise Linux 3 or higher
® CentOS 6

® Java Runtime Environment (JRE) 1.6 or higher

Free Disk Space 2GB
Swap Space RAM*2
Memory 1 GB RAM (minimum); 4 GB is recommended

@ Notes:

WebLOAD components in each major version will work with all other components of
the same version. WebLOAD components are not compatible with other components
of a different version. Verify that the WebLOAD components have been upgraded to
Version 10.0 on all participating hosts. Running WebLOAD Console Version 10.0 with
an earlier version of Load Generator (running on different Hosts) may cause
unexpected behavior.

The WebLOAD license file is limited to the computer system (machine) on which
WebLOAD is initially installed. Before installing WebLOAD, make sure you are
installing on the machine with which you intend to work.

When installing WebLOAD with Unicode support on a system running an English MS
Windows, Japanese must be configured as the default Windows language.

°6 e Chapter 2. System Requirements



J

RADVIEW

pter3

Installing WebLOAD for Windows

This chapter provides step-by-step instructions for installing WebLOAD on a PC
running Windows systems.

Installing WebLOAD for Windows

When you install WebLOAD on your computer, the installation program asks you for
the components to install. As part of the installation process, WebLOAD installs a
database management system (PostgreSQL 8.3) for use with WebLOAD Analytics. For
more information about PostgreSQL, refer to www.postgresqgl-support.de.

Install the WebLOAD components as follows:

* Install the full WebLOAD product on computers that will be used to run the
WebLOAD Console.

* Install only the Load Generator or the Probing Client software on a computer that
will be a dedicated Load Machine. There is no need to install the full product on
computers that will be used as Load Machines.

To install WebLOAD on your system:

1. Browse to the location of the WebLOAD executable (* . exe) installation file.
2. Double-click the file.
The WebLOAD Installation Wizard appears.

3. Follow the instructions in the Installation Wizard.

WEBLOAD 2?Installation Guide o7 o
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4. In the Select Components screen.

e Select the component you would like to install. For Load Machines and
Probing Clients, select Load Generator.

*  Specify whether to install the Load Generator as a service.

* If you select this option, TestTalk is installed as a service. Since a service
can be started automatically, this is especially useful for machines that
serve only as Load Generators.

* If you do not select this option, TestTalk is installed as an executable file.

e Specify whether to also install the WebLOAD Dashboard Server. The Web
Dashboard enables viewing, analyzing and comparing load sessions in a web
browser, with full control and customization of the display.

Note: The installation process is the same for Load Machines and Probing Clients.

When the WebLOAD installation is complete, the WebLOAD License dialog box
automatically opens to complete the registration process. License registration is
discussed in Registering and Updating the WebLOAD License (on page 15).

Installing WebRM

To install WebRM:

1. Browse to the location of the WebRM-10.0.xxx.en.exe installation file.
2. Double-click the file. The WebRM Installation Wizard appears.

3. The WebRM Installation Wizard displays the Choose Destination Location dialog
box. This dialog box displays your HostID and enables you to browse to the
location where you would like WebRM installed.

Note: If you have already received your WebRM License file, skip to step 7.

4. If you have not received your License file, copy the HostID displayed in the text
box into an email, together with your name, company, address, and phone
number. Send the email to support@radview.com.

A WebRM license file (* . 1ic) will be sent to you.

5. After receiving the file, save it on the hard drive of your WebRM machine.

6. Double-click the WebRM executable installation file to restart the installation
process.

e 8 Chapter 3. Installing WebLOAD for Windows
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7. On the Choose Destination Location dialog box, browse to the location where you
would like WebRM installed. By default, this location is C: \Program
Files\RadView\WebRM.

8. Click Next.

9. The Select License dialog box appears. Browse to the location where you saved
your WebRM license, select the file and click Open.

10. WebRM begins the installation. When the WebRM installation process is complete,
a dialog box appears stating that the WebRM installation has completed
successfully. Click Finish.

Upgrading WebLOAD

To upgrade WebLOAD:

1. Close TestTalk.

2. Close all browser windows that are open.

3. Uninstall the existing WebLOAD version.
For instructions on the uninstall procedure, see Uninstalling WebLOAD (on
page 21).

4. Install the new version of WebLOAD.

For installation instructions, see Installing WebLOAD for Windows (on page 7).

Installing and Configuring the WebLOAD Analytics
Database

WebLOAD stores information from Load Sessions in a Postgre SQL database for use
with WebLOAD Analytics. You can install Postgre SQL and the WebLOAD Analytics
database during the WebLOAD installation or manually after WebLOAD has already
been installed. You might want to perform manual installation in the following
situations:

* If Postgre SQL is already installed on your machine and you only need to create
the WebLOAD Analytics database. For instructions, refer to Creating the Database
when Postgre SQL is Already Installed on page 10.

* If you want to use a different machine as the database server and have several
WebLOAD Analytics applications connect to the database. For instructions, refer to
Installing and Configuring the Database on a Dedicated Machine on page 10.

WEBLOAD 2?Installation Guide e Qo
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Creating the Database when Postgre SQL is Already
Installed

If Postgre SQL is already installed on your machine, you do not have to reinstall it
during the WebLOAD installation. However, you must complete the following steps in
order to create the WebLOAD Analytics database in Postgre SQL so that it can be used
by WebLOAD Analytics.

To create the WebLOAD Analytics database after WebLOAD was installed:

* Rundeploy—-database.bat from the C:\Program
Files\RadView\WebLOAD\bin\database folder.

Installing and Configuring the Database on a Dedicated
Machine

You can run the Postgre SQL database using a dedicated machine with several
WebLOAD Analytics client applications.

To install and configure the database on a dedicated machine:
1. Install Postgre SQL.

Note: It is recommended to install Postgre SQL Version 8.3. You can download the
application from http://www.postgresql.org/download/ and install it using its default
installation settings.

2. Copy all the files from the C: \Program
Files\RadView\WebLOAD\bin\database directory to a temporary folder on
the dedicated server.

3. Rundeploy-database.bat from the temporary folder to which you copied the
files in the previous step. The WebLOAD Analytics database is created.

4. Configure Postgre SQL to allow remote connections. For more information, see
Configuring Postgre SQL to Allow Remote Database Connections on page 11.

5. Configure the relevant WebLOAD Analytics clients to work with the remote
database. For more information, see Configuring Clients to Work with the Remote
Database on page 12.

Chapter 3. Installing WebLOAD for Windows
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Configuring Postgre SQL to Allow Remote Database
Connections

For WebLOAD Analytics clients to work with the remote database, you must perform
the following configuration steps on the host machine.

To configure a remote database connection through Postgre SQL:

1. Run Start » PostgreSql 8.3 » PgAdmin III. The PgAdmin III application opens.
2. Edit the postgresqgl.conf file, as follows:
a. Select File » Open.

b. Browseto C:\program files\Postgres\Data), select
postgresqgl.conf, and click Open. The postgresqgl . conf configuration
file opens.

c. Change the value of listen_address to *. This configures the server to listen to
all addresses.

d. Enable the value and save the file.
3. Edit the Pg hba. conf file, as follows:
a. Select File » Open.

b. Browseto C:\program files\Postgres\Data), select Pg hba.conf,
and click Open. The Pg_hba . conf configuration file opens.

c. Add anew entry with the following parameters:

* Type=host

Database = all
e User=all

e [P address = <IP subnet mask>.0.1.1/24, where <IP subnet mask> is your
organization’s IP subnet mask.

¢ Method = md5

d. Enable the entry and save the file.

WEBLOAD 2?Installation Guide e 11 e
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Configuring Clients to Work with the Remote Database

To configure a remote database connection through Postgre SQL:

1
2
3.
4

Open WebLOAD Analytics on the client machine.
Select Window » Preferences » Database.

Enter the server’s IP address and name in the Database host name field.

Click OK.

Installing Third Party Software for Server-side
Monitoring

WebLOAD Console provides a Performance Measurements Manager (PMM) for
monitoring the performance of various data sources such as server-side applications,
databases, stream technology, system, and Web server measurements in real-time
while your test is running.

Some data sources require initial configuration to enable monitoring by the PMM. For
more information, see the Enabling Data Sources Monitoring section in the WebLOAD
Console User’s Guide.

e 12 e
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Installing WebLOAD for Linux

This chapter contains the instructions for installing the WebLOAD Load Engine on a

machine running a Linux operating system.

Installing the WebLOAD Load Engine for Linux

N
N\

To install the WebLOAD Load Engine on your system:

1.

Select or create a directory for installing the WebLOAD Load Engine. This
directory will be referred to as the working directory.

Download the WebLOAD-1linux.version.tar.gz compressed file from a server
to the working directory.

Uncompress and extract the tar file in the working directory using the following
command:

tar -zvxf WebLOAD-linux-version.tar.gz

Change directories by typing the following:

cd radview/webload<version number>/linux/bin

Run setup by typing the following;:
./setup

During the setup process, the webload. ini configuration file is created.

When prompted, enter the path to the Java runtime libraries. The default path to
the libraries is displayed. If you are working with a different version of Java, enter
the path of the libraries using the following:

/usr/java/jre/lib/i386/server:/usr/java/jre/lib/i386/native-threads

The path information is stored in the LD LIBRARY PATH variable.

Note: The directories containing the Java libraries are separated with a colon (:).

Important: The WebLOAD Load Generator will not function properly without the
correct paths for the Java libraries.

WEBLOAD 2?Installation Guide e 13
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Running the Load Engine on Linux

When running the Load Engine on Linux, Load Engine runs with TestTalk.

TestTalk enables communication between the different components of the WebLOAD
module. When running the Load Generator through Linux you generally need to
connect with other WebLOAD modules running on a remote Windows machine (for
example WebLOAD Console). To connect with these remote modules, you must run
TestTalk. Once TestTalk is running, you can access the remote WebLOAD modules.
The remote module then initiates the communication with TestTalk and then TestTalk
loads the Load Generator.

Note: If the Load Generator is running and TestTalk is not running, the remote
WebLOAD application will not be able to access the Load Generator.

To run TestTalk on your system:

1. Open the 1inux/bin directory within your working directory by typing the
following:

cd <working-directory>/linux/bin

2. Run TestTalk by typing the following:
./starttestalk

TestTalk starts running.

To stop running TestTalk:

* From the 1inux/bin directory, run . /stoptesttalk

Installing Third Party Software for Server-side
Monitoring

WebLOAD Console provides a Performance Measurements Manager (PMM) for
monitoring the performance of various data sources such as server-side applications,
databases, stream technology, system, and Web server measurements in real-time
while your test is running.

Some data sources require initial configuration to enable monitoring by the PMM. For
more information, see the Enabling Data Sources Monitoring section in the WebLOAD
Console User’s Guide.

e 14 o
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Registering and Updating the
WebLOAD License

Your WebLOAD license must be registered before you can start working with
WebLOAD. WebLOAD licenses that have expired must also be renewed or updated
before you can continue working with WebLOAD. When installing a new major or
minor version of WebLOAD, make sure that you have an adequate license for that
specific version. All license registration and updating is accomplished through the
Update License dialog box.

Standard License Registration

<P

To open the Update License dialog box:

* At the time of WebLOAD installation, when the WebLOAD Installation Wizard is
finished, the License dialog box opens automatically,

Note: After a WebLOAD installation, you may be prompted to restart your
computer before the Update License dialog box appears. In this case, the License
dialog box will appear automatically after the computer restarts.

-Or-

At any other time, from the Windows desktop, select Start » Programs »
RadView » WebLOAD > Utilities » Update License.

The License dialog box includes the following sections:

* License Details
* Update License

These sections are used to register and update your WebLOAD authorization license
information.

WEBLOAD 2?Installation Guide
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To complete or update your license registration:

1.

If you are registering a new license after an initial WebLOAD installation, access
the Update License dialog box. The Update License dialog box is opened
automatically after a successful WebLOAD installation is completed.

-Or-

If you are updating your license registration after your current license has expired,
from the Windows desktop, select Start » Programs » RadView » WebLOAD »
Utilities » Update License.

The Update License dialog box appears.

&% Update License g|
Licenze Details
_E_"l . Status Walid | Lizense [nfarmation |
:r “ Number of Yirtual Clients 200
Expiration date 30-un-2011
Host 1d 00256481316

|Jpdate Licenze

() Evaluate WebLOAD

() Use a license file E]

() Connect to the WebFiM Licenze Server

[ Apply ] [ QK. ] [ Cancel

Figure 1: Update License Dialog Box

Create an email message with the following information:
a. Copy the Host ID displayed in the text box into the email.
b. Add your name, company, address, and phone number to the email message.

Send the email to license@radview.com.

A WebLOAD license file (* . 1ic) will be sent to you.
Select Start » Programs » RadView » WebLOAD » Utilities » Update License
to open the Update License dialog box and install the license key.

By default, the Use a license file radio button is selected. This assumes that your
license file is located on your local computer system.

For information on installing a floating license, or connecting to a license server,
see WebRM Server (on page 17).

e 16 e
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6. Click the browse button next to the Use a license file text box to browse to the
location of the license (* . 1ic) file sent to you by a RadView representative.

7. Select the correct license file and click Open to return to the Update License dialog
box.

8. Click OK to load the new license.
If the license registration was successful, a message box appears indicating a

successful license update.

You can now begin working with WebLOAD.

Note: After loading the license, you can optionally click License Information to view
the license’s full details.

If the license registration was not successful, an error message appears.

If you are not able to successfully register a valid license file, contact RadView
Support for assistance.

WebRM Server

The WebRM Server is a stand-alone tool that manages all resource distribution to
WebLOAD Console, which is the machine used to run loads in a WebRM environment.
It is the method that controls the number of users allowed to access the product
concurrently.

WebRM for virtual clients is available and defined as a pool of virtual (probing) clients
that can concurrently be used by members of a testing team and monitored by the
WebRM Server.

During installation of the WebRM server, you are prompted for the WebRM file that
defines:

* The number of concurrent applications for the WebLOAD Console.

*  The number of concurrent Virtual and Probing Clients.

Installation also creates a FlexLM Service that controls the operation.

The WebRM Server displays a list of the number of resources (Virtual and Probing

Clients) that the Console is using. The WebRM Server enables a testing team to share
resources.

This section describes how to connect to the WebRM Server and how to view the
license details.

WEBLOAD 2?Installation Guide e 17 «
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1. After installing WebLOAD, the Update License dialog box opens, enabling you to

select a valid license key,

-Or-

To open the Update License dialog box manually, select Start » Programs »

RadView » WebLOAD » Utilities » Update License.

The Update License dialog box appears.

x)

§% Update License
Licenze Details
ry Status " alid [ Lisenze Infarmation
EI"“ Number of Yirtual Clients 200
Expiration date 30+un-2011
Host 1d 00256481316

Update Licenze

() Evaluate WebLOAD

() Use a license file |

]

() Connect to the WebFiM Licenze Server |

[ Apply ] [ QK ][ Cancel ]

Figure 2: Update License Dialog Box — WebRM Server Installation

2. Select Connect to the WebRM License Server.

3. Click the Browse button and select the machine where WebRM is installed.

4. Click OK.

A connection to the selected license server is attempted.

e If the connection is successful, a success message appears.

e If the connection is not successful, a failure message appears.

Viewing License Details

After selecting the license server, you can view the current license details in the License

Details section of the Update License dialog box.

e 18 o
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Configuring Connection to the Oracle
Database using WebLOAD

Connecting to the Oracle Database using WebLOAD requires that you install the
Oracle Data Access Components (ODAC) on your computer. For information on
ODACG, refer to the appropriate Oracle documentation.

<> Note: You need to be assigned a valid username and user privileges for Oracle so that
you can connect to the Oracle database.

The following procedure is confirmed to work with Oracle Database version 11g, and is
also expected to work with Oracle Database version 10g.

To configure your computer to enable connection to the Oracle database using
WebLOAD:
1. Navigate to SORACLE HOME\NETWORK\ADMIN.

2. Open tnsnames.ora for editing.

@ Note: If tnsnames.ora does not exist, create it.

The default content is as follows:

<tns name> =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP) (HOST = <host or ip>) (PORT = 1521))
(CONNECT DATA =
(SERVER = DEDICATED)
(SERVER NAME = <instance name>)
)

3.  Make the following definitions in the file:
tns_name = <tns name configured in the listener on the server (default orcl)>
host = <hostname or IP address of the server>
instance name = <instance configured on the server (default orcl)>

Log out and log in, or restart, to activate the environmental variables.
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Uninstalling WebLOAD

When you uninstall WebLOAD, you are prompted to remove PostgreSQL 8.3, which is
used to manage the WebLOAD Analytics database. RadView Software recommends
that you keep PostgreSQL 8.3 installed in order to maintain all the information stored
in the database.

To uninstall WebLOAD:

1. Close all WebLOAD modules including TestTalk.

2. Close all browser windows that are open.

3. Select Start » Settings » Control Panel.

4. Double-click the Add/Remove Programs icon.

5. Click the Change or Remove Programs tab.

6. Click Radview WebLOAD Professional, and then click Change/Remove.

The Uninstall Wizard appears. Once the uninstall procedure is complete, you may
be prompted to restart your machine.

Note: Uninstalling WebLOAD removes all the WebLOAD program file directories,
including all the WebLOAD installation files. User files that are copied into these
directories (such as user-defined extensions) are not deleted. WebLOAD load

templates, load sessions, and Agenda files are not removed — they can be used with all
WebLOAD upgrades.

Caution: Close TestTalk and all browser windows before uninstalling WebLOAD.
Failure to close TestTalk and all browser windows results in outdated files remaining
on your disk, which could adversely affect future installations of the program.

To uninstall WebRM:

1. Select Start » Settings » Control Panel.

2. Double-click the Add/Remove Programs icon.

3. Click the Add or Remove Programs tab.

4. Click RadView WebRM, and then click Change/Remove.
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The Uninstall Wizard appears. The uninstall procedure is completed following a
confirmation request.
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