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Introduction

Welcome to WebLOAD Professional, the premier performance, scalability, and
reliability testing solution for internet applications.

WebLOAD is easy to use and delivers maximum testing performance and value.
WebLOAD verifies the scalability and integrity of internet applications by generating a
load composed of Virtual Clients that simulate real-world traffic. Probing Clients let
you refine the testing process by acting as a single user that measures the performance
of targeted activities, and provides individual performance statistics of the internet
application under load.

This section provides a brief introduction to WebLOAD technical support, including
both documentation and online support.

WebLOAD Documentation

WebLOAD is supplied with the following documentation:

WebLOAD™ Installation Guide
Instructions for installing WebLOAD and its add-ons.

WebLOAD™ IDE User’s Guide

Instructions for recording, editing, and debugging load test Agendas to be
executed by WebLOAD to test your Web-based applications.

WebLOAD™ Console User’s Guide

A guide to using WebLOAD console, RadView’s load/scalability testing tool to
easily and efficiently test your Web-based applications. This guide also includes a
quick start section containing instructions for getting started quickly with
WebLOAD using the RadView Software test site.

WEBLOAD? Installation Guide o] e
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WebLOAD™ Analytics User’s Guide

Instructions on how to use WebLOAD Analytics to analyze data and create
custom, informative reports after running a WebLOAD test session.

WebRM™ User’s Guide

Instructions for managing testing resources with the WebLOAD Resource
Manager.

WebLOAD™ Scripting Guide

Complete information on scripting and editing JavaScript Agendas for use in
WebLOAD and WebLOAD IDE.

WebLOAD™ JavaScript Reference Guide

Complete reference information on all JavaScript objects, variables, and functions
used in WebLOAD and WebLOAD IDE test Agendas.

WebLOAD™ Extensibility SDK

Instructions on how to develop extensions to tailor WebLOAD to specific working
environments.

The guides are distributed with the WebLOAD software in online help format. The
guides are also supplied as Adobe Acrobat files. View and print these files using the
Adobe Acrobat Reader. Install the Reader from the Adobe website
http://www.adobe.com.

Typographical Conventions

Before you start using this guide, it is important to understand the terms, icons, and
typographical conventions used in the documentation.

The following icons appear next to the text to identify special information.

Table 1: Icon Conventions

Icon Type of Information

@ Indicates a note.

C-:3> Indicates a feature that is available
X only as part of a WebLOAD Add-on.

° 2 Chapter 1. Introduction
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The following kinds of formatting in the text identify special information.

Table 2: Typographical Conventions

Formatting Type of Information
convention

Special Bold Items you must select, such as menu options, command buttons,
or items in a list.

Emphasis Use to emphasize the importance of a point or for variable
expressions such as parameters.

CAPITALS Names of keys on the keyboard. for example, SHIFT, CTRL, or
ALT.
KEY+KEY Key combinations for which the user must press and hold down

one key and then press another, for example, CTRL+P or ALT+F4.

Where to Get More Information
This section contains information on how to obtain technical support from RadView
worldwide, should you encounter any problems.
Online Help

WebLOAD provides a comprehensive on-line help system with step-by-step
instructions for common tasks.

You can press the F1 key on any open dialog box for an explanation of the options or
select Help » Contents to open the on-line help contents and index.
WebLOAD Open Source Community Website

The WebLOAD Open Source Community website at http://www.webload.org contains
many sources of information for both WebLOAD users and developers:

*  Forums

* Script Library

*  Documentation
* How To docs

* FAQ

*  Developer Wiki

WEBLOAD? Installation Guide e 3
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The technical support pages on our website contain:

* FAQ (Frequently Asked / Answered Questions).

* Agenda Center

e Documentation

* RadView’s Product Resource Center, where you can find prepared test scripts,
product information, and industry related news.

e http://www.radview.com/support/index.asp

Technical Support

For technical support in your use of this product, contact:

North American Headquarters

International Headquarters

e-mail: support@RadView.com

Phone: 1-888-RadView
(1-888-723-8439) (Toll Free)
908-526-7756

Fax:  908-864-8099

e-mail: support@RadView.com
Phone: +972-3-915-7060
Fax: +972-3-915-7683

Note: We encourage you to use e-mail for faster and better service.

When contacting technical support please include in your message the full name of the
product, as well as the version and build number.

Chapter 1. Introduction
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WebLOAD has the following system requirements. WebLOAD Console, WebLOAD
IDE, WebLOAD Analytics, WebLOAD Probing Client, and WebRM can only be run on
Windows platforms. WebLOAD Load Machines can be run on Windows, Solaris, and
Linux platforms.

Windows Platforms

Table 3: WebLOAD System Requirements

Requirements

WebLOAD Console, WebLOAD
IDE, WebLOAD Analytics,
WebLOAD Probing Client, and
WebRM

Load Machine

Computer / Processor

IBM-compatible PC (x86-32) with
Pentium III 800 MHz (or higher)
MiCroprocessor

IBM-compatible PC (x86-32) with
Pentium III 800 MHz (or higher)
microprocessor; Pentium 4 is

recommended
Operating System * Windows 2000 Professional * Windows 2000 Server /
* Windows XP Pro (SP2) Advanced Server
* Windows Server 2003 * Windows XP Pro (SP2)
®* Windows Server 2003, Standard
and Enterprise Editions
Memory 512 MB RAM (minimum); 1 GB is 512 MB RAM (minimum); 1 GB is
recommended recommended
Free Disk Space 260 MB 260 MB

WEBLOAD? Installation Guide
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Linux Platforms (for WebLOAD Load Machines)

Table 4: WebLOAD Load Machine System Requirements

Requirements Load Machine

Hardware IBM-compatible PC (x86-32) with Pentium III 800
MHz (or higher) microprocessor; Pentium 4 is
recommended

Version ® Fedora Core3/6

* Red Hat Enterprise Linux3/4/5

® Java Runtime Environment (JRE) 1.5 or higher

Free Disk Space 175 MB
Swap Space RAM*2
Memory 256 MB RAM (minimum); 1 GB is recommended

Solaris Platforms (for WebLOAD Load Machines)

The system requirements for the Solaris version for WebLOAD 8.x Load Machines will
be published separately.

<b Notes:

WebLOAD components in each major version will work with all other components of
the same version, no matter what the minor revision number. WebLOAD components
are not compatible with other components of a different version. For example, all
components of WebLOAD Version 7.x will work with each other. Version 7.0, 7.1, etc,
are all compatible with each other. However, components of Version 7.x are not
compatible with components of Version 6.x or Version 5.x. Verify that the WebLOAD
components have been upgraded to Version 7.x on all participating hosts. Running
WebLOAD Console Version 7.x with an earlier version of Load Generator (running on
different Hosts) may cause unexpected behavior.

Starting with WebLOAD 8.1, it is possible to install different versions of WebLOAD
side-by-side on the same machine. Although this usage is not recommended, it is
supported as it may be necessary in some cases. For example, you can install
TestView 8.0 and WebLOAD 8.1 on the same machine. In such a case, each version has
its own Start menu shortcuts and a different set of program files, directories, and
settings. However, be sure not to execute components of different versions
simultaneously. When you need to switch between the versions, verify that no
RadView software processes are running.

Chapter 2. System Requirements
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The WebLOAD license file is limited to the computer system (machine) on which
WebLOAD is initially installed. Before installing WebLOAD, make sure you are
installing on the machine with which you intend to work.

When installing WebLOAD with Unicode support on a system running an English MS
Windows, Japanese must be configured as the default Windows language.

WEBLOAD? Installation Guide
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Installing WebLOAD for Windows

This chapter provides step-by-step instructions for installing WebLOAD on a PC
running Windows 2000, Windows 2003, or Windows XP systems.

Installing WebLOAD for Windows

When you install WebLOAD on your computer, the installation program asks you for
the components to install. As part of the installation process, WebLOAD installs a
database management system (PostgreSQL 8.2) for use with WebLOAD Analytics. For
more information about PostgreSQL, refer to www.postgresql-support.de.

Install the WebLOAD components as follows:
* Install the full WebLOAD product (with or without WebLOAD Analytics) on
computers that will be used to run the WebLOAD Console.

* Install only the Load Generator or the Probing Client software on a computer that
will be a dedicated Load Machine. There is no need to install the full product on
computers that will be used as Load Machines.

To install WebLOAD on your system:

1. Browse to the location of the WebLOAD executable (* . exe) installation file.
2. Double-click the file.
The WebLOAD Installation Wizard appears.

3. Follow the instructions on your screen.

4. When the Installation Wizard prompts for the component to install, select the
desired component. For Load Machines and Probing Clients, select Load
Generator.

WEBLOAD? Installation Guide °e Qe
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5. When the Installation Wizard prompts for the installation method of TestTalk,
select one of the following:

e Executable — Installs TestTalk as an executable file.

e Service — Installs TestTalk as a service. Since a service can be started
automatically, this is especially useful for machines that serve only as Load
Generators.

<> Note: The installation process is the same for Load Machines and Probing Clients.

When the WebLOAD installation is complete, the WebLOAD License dialog box
automatically opens to complete the registration process. License registration is
discussed in Registering and Updating the WebLOAD License (on page 19).

Installing WebRM

To install WebRM:

1. Browse to the location of the WebRM-8.4 .xxx.en.exe installation file.
2. Double-click the file. The WebRM Installation Wizard appears.

3. The WebRM Installation Wizard displays the Choose Destination Location dialog
box. This dialog box displays your HostID and enables you to browse to the
location where you would like WebRM installed.

<> Note: If you have already received your WebRM License file, skip to step 7.

4. If you have not received your License file, copy the HostID displayed in the text
box into an email, together with your name, company, address, and phone
number. Send the email to support@radview.com.

A WebRM license file (* . Iic) will be sent to you.

5. After receiving the file, save it on the hard drive of your WebRM machine.

6. Double-click the WebRM executable installation file to restart the installation
process.

7. On the Choose Destination Location dialog box, browse to the location where you
would like WebRM installed. By default, this location is C2\Program
Files\RadView\WebRM.

8. Click Next.

9. The Select License dialog box appears. Browse to the location where you saved
your WebRM license, select the file and click Open.

*10 - Chapter 3. Installing WebLOAD for Windows
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10. WebRM begins the installation. When the WebRM installation process is complete,
a dialog box appears stating that the WebRM installation has completed
successfully. Click Finish.

Upgrading WebLOAD

To upgrade WebLOAD:

1. Close TestTalk.

2. Close all browser windows that are open.

3. Uninstall the existing WebLOAD version.
For instructions on the uninstall procedure, see Uninstalling WebLOAD (on
page 27).

4. Install the new version of WebLOAD.

For installation instructions, see Installing WebLOAD for Windows (on page 9).

Installing and Configuring the WebLOAD Analytics
Database

WebLOAD stores information from Load Sessions in a Postgre SQL database for use
with WebLOAD Analytics. You can install Postgre SQL and the WebLOAD Analytics
database during the WebLOAD installation or manually after WebLOAD has already
been installed. You might want to perform manual installation in the following
situations:

* If Postgre SQL is already installed on your machine and you only need to create
the WebLOAD Analytics database. For instructions, refer to Creating the Database
when Postgre SQL is Already Installed on page 11.

* If you want to use a different machine as the database server and have several
WebLOAD Analytics applications connect to the database. For instructions, refer to
Installing and Configuring the Database on a Dedicated Machine on page 12.

Creating the Database when Postgre SQL is Already
Installed

If Postgre SQL is already installed on your machine, you do not have to reinstall it
during the WebLOAD installation. However, you must complete the following steps in
order to create the WebLOAD Analytics database in Postgre SQL so that it can be used
by WebLOAD Analytics.

WEBLOAD? Installation Guide e 11
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To create the WebLOAD Analytics database after WebLOAD was installed:

* Run deploy—database.bat from the C:\Program
Files\RadView\WebLOAD\bin\database folder.

Installing and Configuring the Database on a Dedicated
Machine

You can run the Postgre SQL database using a dedicated machine with several
WebLOAD Analytics client applications.

To install and configure the database on a dedicated machine:
1. Install Postgre SQL.

Note: It is recommended to install Postgre SQL Version 8.2. You can download the
application from http://www.postgresgl.org/download/ and install it using its
default installation settings.

2. Copy all the files from the C:\Program
Files\RadView\WebLOAD\bin\database directory to a temporary folder on
the dedicated server.

3. Run deploy—database.bat from the temporary folder to which you copied the
files in the previous step. The WebLOAD Analytics database is created.

4. Configure Postgre SQL to allow remote connections. For more information, see
Configuring Postgre SQL to Allow Remote Database Connections on page 12.

5. Configure the relevant WebLOAD Analytics clients to work with the remote
database. For more information, see Configuring Clients to Work with the Remote
Database on page 13.

Configuring Postgre SQL to Allow Remote Database
Connections

For WebLOAD Analytics clients to work with the remote database, you must perform
the following configuration steps on the host machine.

To configure a remote database connection through Postgre SQL:

1. Run Start » PostgreSql 8.2 » PgAdmin III. The PgAdmin III application opens.
2. Edit the postgresqgl . conf file, as follows:
a. Select File » Open.

e 12 e
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b. Browse to C:\program Files\Postgres\Data\, select
postgresqgl .conf, and click Open. The postgresql . conf configuration
file opens.

c. Change the value of listen_address to *. This configures the server to listen to
all addresses.

d. Enable the value and save the file.

3. Edit the Pg_hba. conf file, as follows:

a. Select File » Open.

b. Browse to C:\program Files\Postgres\Data\, select Pg_hba.conf,
and click Open. The Pg_hba. conT configuration file opens.

c. Add anew entry with the following parameters:

* Type =host
e Database = all
e User=all

* IP address = <IP subnet mask>.0.1.1/24, where <IP subnet mask> is your
organization’s IP subnet mask.

* Method =md5

d. Enable the entry and save the file.

Configuring Clients to Work with the Remote Database

To configure a remote database connection through Postgre SQL:

1. Open WebLOAD Analytics on the client machine.
2. Select Window » Preferences » Database.
3. Enter the server’s IP address and name in the Database host name field.
4. Click OK.
WEBLOAD? Installation Guide e 13
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Installing WebLOAD for Linux

This chapter contains the instructions for installing the WebLOAD Load Engine on a
machine running a Linux operating system.

Installing the WebLOAD Load Engine for Linux

To install the WebLOAD Load Engine on your system:

1. Select or create a directory for installing the WebLOAD Load Engine. This
directory will be referred to as the working directory.

2. Download the WebLOAD-1inux.version.tar.gz compressed file from a server
to the working directory.

3. Uncompress and extract the tar file in the working directory using the following
command:

tar —zvxft WebLOAD-linux-version.tar.gz

4. Change directories by typing the following;:
cd radview/webload<version number>/linux/bin

5. Run setup by typing the following;:
./setup

During the setup process, the webload. ini configuration file is created.

6. When prompted, enter a value for the DISPLAY variable. This is the IP address of
the session’s X server, followed by the screen address, in the following format:
<X server IP>:<screen address>.If the X server is running on a local
machine, press Enter and use the default option (localhost:0).

<b Note: If the DISPLAY variable is not valid, a message displays with the option to enter
a new value or continue with the specified value. An incorrect value can be corrected
later using the ./env_setup utility in the <working-directory>/1inux/bin
directory before starting TestTalk.

WEBLOAD? Installation Guide e 15
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Important: If the DISPLAY addresses are correct, but do not allow connections, the
setup may freeze during the validity check it performs on the DISPLAY variable. In this
case, press Ctrl-C. The setup script need not be rerun. Check the accuracy of the
DISPLAY variable and use ./env_setup to complete the installation.

7. When prompted, enter the path to the Java runtime libraries. The default path to
the libraries is displayed. If you are working with a different version of Java, enter
the path of the libraries using the following:

/usr/java/jre/lib/i386/server:/usr/java/jre/lib/i386/native-threads

The path information is stored in the LD_L IBRARY_PATH variable.

Note: The directories containing the Java libraries are separated with a colon (:).

Important: The WebLOAD Load Generator will not function properly without the
correct paths for the Java libraries.

8. Change the value of the TV_TOP variable in the webload.ini configuration file
from:

/home/loadtv/TS2004/1inux8.0.5

to:

/<path to working directory>

The Load Machine is installed.

Running the Load Engine on Linux

When running the Load Engine on Linux, you can select one of the following methods:

* Running the Load Engine with TestTalk — The standard method used when
running the Load Engine on Linux, which enables you to connect to other
WebLOAD modules.

* Running the Load Machine in standalone mode — An alternative method, which
can be used to run the Load Engine independently without being controlled by
external WebLOAD modules.

Running the Load Engine with TestTalk

TestTalk enables communication between the different components of the WebLOAD
module. When running the Load Generator through Linux you generally need to
connect with other WebLOAD modules running on a remote Windows machine (for

e 16
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example WebLOAD Console). To connect with these remote modules, you must run
TestTalk. Once TestTalk is running, you can access the remote WebLOAD modules.
The remote module then initiates the communication with TestTalk and then TestTalk
loads the Load Generator.

TestTalk references the DISPLAY and Java libraries paths variables that are defined
during setup in the WebLOAD.ini configuration file to create the application
environment. These variables can be modified using the ./env_setup utility. When the
utility is run, the default settings are displayed and can be modifed, as required.

<> Note: If the Load Generator is running and TestTalk is not running, the remote
WebLOAD application will not be able to access the Load Generator.

To run TestTalk on your system:

1.  Open the Iinux/bin directory within your working directory by typing the
following;:

cd <working-directory>/linux/bin

2. Type ./env_setup.

This script prompts the user to set the DISPLAY and LD_LIBRARY_PATH
environment variables:

e DISPLAY - Enter the IP address of the session’s X server, followed by the
screen address, as follows: “your X server IP’:"screen address’.
If you are running an X server on a local machine, enter 0:0.

e LD_LIBRARY_PATH - Specify the location of the shared library used by the
WebLOAD engine.

You can use the env_setup script’s default path:
<working-directory>/linux/lib:<working-
directory>/linux/syslib

3. Run TestTalk by typing the following:
./starttestalk

TestTalk starts running.

To stop running TestTalk:

*  From the Iinux/bin directory, run ./stoptesttalk

WEBLOAD? Installation Guide ° 17 e
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Running the Load Generator in StandAlone Mode

The Load Generator has the option of being run in a standalone mode. During the
standalone mode, the Load Generator works independently and is not controlled by
the Console application.

To run the Load Generator in standalone mode:

1. Open the Iinux/bin directory within your working directory by typing the
following;:

cd <working-directory>/linux/bin

2. Modify the LD_L IBRARY_PATH global variable by typing the following:

setenv LD_LIBRARY_PATH <path to working-
directory>/linux/lib:<path to working-directory>/linux/syslib

3. Run the Load Generator application by typing the following;:
./httploadl28 test.js -r:10

Where:

e test.js is the specific Agenda that the load test is executing

e 1 is the execution rounds number

e 18 e
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Registering and Updating the
WebLOAD License

Your WebLOAD license must be registered before you can start working with
WebLOAD. WebLOAD licenses that have expired must also be renewed or updated
before you can continue working with WebLOAD. When installing a new major or
minor version of WebLOAD, make sure that you have an adequate license for that
specific version. All license registration and updating is accomplished through the
Update License dialog box.

Standard License Registration

N\

To open the Update License dialog box:

e At the time of WebLOAD installation, when the WebLOAD Installation Wizard is
tinished, the License dialog box opens automatically,

Note: After a WebLOAD installation, you may be prompted to restart your
computer before the Update License dialog box appears. In this case, the License
dialog box will appear automatically after the computer restarts.

-Or-

At any other time, from the Windows desktop, select Start » Programs »
RadView » WebLOAD » Utilities » Update License.

The License dialog box includes three tabs:

e HostID
* Select License
¢ License Information

These tabs are used to register and update your WebLOAD authorization license
information.

WEBLOAD? Installation Guide
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To complete or update your license registration:

1.

If you are registering a new license after an initial WebLOAD installation, access
the Update License dialog box. The Update License dialog box is opened
automatically after a successful WebLOAD installation is completed.

-Or-

If you are updating your license registration after your current license has expired,
from the Windows desktop, select Start » Programs » RadView » WebLOAD >
Utilities » Update License.

Select the Host ID tab.

[Rupostevcense x

Hast ID |Select License | License Information |

To obtain icense keys for Badyiew software pleaze include the Host 1D,
showin below, in an email with pour licenze request to one aof the fallowing
addresses:

For Product Evaluations: license@radview. com
For Mew Product Purchases: ordersi@radview. com
For Product Upgrades: B.Oupgradet@radview, com

Once you have received your license file pleaze place it
in the following directary:
C:AProgram Filesh R adyviewt T estyiewhLicense

Toreach Badview Software by phone pleaze contact uz at
one of the following locations:

US Canada: [388) RADAIEW [F23-8439]

UK Office; +44(0) 207 716 5340

German Office: +49 [89) 238853960

International Headguarters: +972 (3] 9157060
All other Teritories: (888] RADAYIEW [723-8439)

Host 1d:

ak. I Cancel

Figure 1: Host ID Tab

Create an email message with the following information:

e. Copy the Host ID displayed in the text box into the email.

f. Add your name, company, address, and phone number to the email message.
Send the email to license@radview.com.

A WebLOAD license file (*. I'ic) will be sent to you.

After receiving the file, save it to your hard drive in the following directory:

C:\<WebLOAD Installation Directory>\License

Select Start » Programs » RadView » WebLOAD » Utilities » Update License
to open the Update License dialog box and install the license key.
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7. Select the Select License tab.

10.

T S —

Host D Select License |License Informationl

Broweze for the licenze key [*lic) received fram pour B adview
reprezentative and click OF, to inztall it If pou do not have a licenze file,
pleaze contact a Badview representation at one of the following addresses:

For Product Evaluations: licensel@radviaw. com
For Mew Product Purchagzes: orders@radview. com
For Product Uparades: upgraded@iradyiew. com

By Phane:

U5 Canada: [888] RaD-VIEW [723-8439]

L. Dffice: +44(0] 207 716 5840

German Office; +49 [39) 23885560

International Headguarters: +372 (3] 3157060
All other Teritonies: [S$88) RADAIEW [723-8439)

" License server

| |

% License file

| |

QK. I Cancel

Figure 2: Select License Tab

R
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:
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By default, the License file radio button is selected. This assumes that your license
file is located on your local computer system.

For information on installing a floating license, or connecting to a license server,
see WebRM Server (on page 23).

Click the Browse button next to the License file text box to browse to the location

of the license (*. lic) file sent to you by a RadView representative.

Select the correct license file and click Open to return to the Update License dialog

box.
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T x

Host D Select License |License Informationl

Broweze for the licenze key [*lic) received fram pour B adview
reprezentative and click OF, to inztall it If pou do not have a licenze file,
pleaze contact a Badview representation at one of the following addresses:

For Product Evaluations: licensel@radviaw. com
For Mew Product Purchagzes: orders@radview. com
For Product Uparades: upgraded@iradyiew. com

By Phane:

U5 Canada: [888] RaD-VIEW [723-8439]

L. Dffice: +44(0] 207 716 5840

German Office; +49 [39) 23885560

International Headguarters: +372 (3] 3157060
All other Teritonies: [S$88) RADAIEW [723-8439)

" License server

| |

% License file

| |
QK. I Cancel |

Figure 3: Update License Dialog Box

11. Click OK to load the new license.

If the license registration was successful, a message box appears indicating a
successful license update.

You can now begin working with WebLOAD.
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If the license registration was not successful, an error message appears in the
License Information tab.

x

Host D I Select License  License Information |

Error loading license file.
Invalid {(inconsistent) license key

QK. I Cancel

Figure 4: License Update Error Message

If you are not able to successfully register a valid license file, contact RadView
Support for assistance.

WebRM Server

The WebRM Server is a stand-alone tool that manages all resource distribution to
WebLOAD Console, which is the machine used to run loads in a WebRM environment.
It is the method that controls the number of users allowed to access the product
concurrently.

WebRM for virtual clients is available and defined as a pool of virtual (probing) clients
that can concurrently be used by members of a testing team and monitored by the
WebRM Server.

During installation of the WebRM server, you are prompted for the WebRM file that
defines:

*  The number of concurrent applications for the WebLOAD Console.

* The number of concurrent Virtual and Probing Clients.

Installation also creates a FlexLM Service that controls the operation.
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The WebRM Server displays a list of the number of resources (Virtual and Probing
Clients) that the Console is using. The WebRM Server enables a testing team to share
resources.

This section describes how to connect to the WebRM Server and how to view the

license details.

Connecting to the WebRM Server

To connect to the WebRM Server:

1. After installing WebLOAD, the Update License dialog box opens, enabling you to
select a valid license key,

-Or-

To open the Update License dialog box manually, select Start » Programs »
RadView » WebLOAD » Utilities » Update License.

[Ropootetcense = x

Host D |Se|ect License | License Infarmation |

To ohtain license keys for Badview software please include the Host 1D,
shown below, in an email with wour license request to one of the following
addresses:

For Product Evaluations: licensel@radviaw. com
For Mew Product Purchagzes: orders@radview. com
Faor Product Uparades: 6.Oupgradet@radview. com

Once you have received your licenze file please place it,
in the following directon:
C:"Program FileshB adview' T esfiewiLicense

Tao reach Radview Saftware by phone please contact us at
one of the following locations:

U5 Canada: [888] RaD-VIEW [723-8439]

L. Dffice: +44(0] 207 716 5840

German Office; +49 [39) 23885560

International Headguarters: +372 (3] 3157060
All other Teritonies: [S$88) RADAIEW [723-8439)

Huost Id:

QK. I Cancel

Figure 5: Update License Dialog Box

2. Select the Select License tab.
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I R Update License x|
Host D Select License |License Informationl

Broweze for the licenze key [*lic) received fram pour B adview
reprezentative and click OF, to inztall it If pou do not have a licenze file,
pleaze contact a Badview representation at one of the following addresses:

For Product Evaluations: licensel@radviaw. com
For Mew Product Purchagzes: orders@radview. com
For Product Uparades: upgraded@iradyiew. com

By Phane:

U5 Canada: [888] RaD-VIEW [723-8439]

L. Dffice: +44(0] 207 716 5840

German Office; +49 [39) 23885560

International Headguarters: +372 (3] 3157060
All other Teritonies: [S$88) RADAIEW [723-8439)

" License server

| |

% License file

| |
QK. I Cancel |

Figure 6: Select License Tab

3. Select License server.
4. C(Click the Browse button and select the machine where WebRM is installed.
5. Click OK.

A connection to the selected license server is attempted.

e If the connection is successful, a success message appears.

e If the connection is not successful, a failure message appears.
Viewing License Details

After selecting the license server, you can view the current license details.

To view license details:

1. Select Start » Programs » RadView » WebLOAD > Utilities » Update License.
2. Select the License Information tab.

All of the current license information is displayed, including free resources, license
features and user details.
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R update License |
Host ID | Select Licenss ~ License Infaimation |
License Information =]
License type: Floating License.
License serwver name: LIBAN
License expiration date: permanent
Licensed to :
test
radvienr
isreael
License produacts:
WMebLOAT
WMebFT b
TestView
License Resources:
Name Total Available
WebLOAT 1 1
Virtual Clients 10000 10000 :I
ak. I Caticel | Help |

Figure 7: License Details
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Uninstalling WebLOAD

When you uninstall WebLOAD, you are prompted to remove PostgreSQL 8.2, which is
used to manage the WebLOAD Analytics database. RadView Software recommends
that you keep PostgreSQL 8.2 installed in order to maintain all the information stored
in the database.

To uninstall WebLOAD:

Close all WebLOAD modules including TestTalk.

Close all browser windows that are open.

Select Start » Settings » Control Panel.

Double-click the Add/Remove Programs icon.

Click the Change or Remove Programs tab.

Click Radview WebLOAD Professional, and then click Change/Remove.

AL

The Uninstall Wizard appears. Once the uninstall procedure is complete, you may
be prompted to restart your machine.

Note: Uninstalling WebLOAD removes all the WebLOAD program file directories,
including all the WebLOAD installation files. User files that are copied into these
directories (such as user-defined extensions) are not deleted. WebLOAD load

templates, load sessions, and Agenda files are not removed — they can be used with all
WebLOAD upgrades.

Caution: Close TestTalk and all browser windows before uninstalling WebLOAD.
Failure to close TestTalk and all browser windows results in outdated files remaining
on your disk, which could adversely affect future installations of the program.

To uninstall WebRM:

1. Select Start » Settings » Control Panel.

2. Double-click the Add/Remove Programs icon.

3. Click the Add or Remove Programs tab.

4. Click RadView WebRM, and then click Change/Remove.

WEBLOAD? Installation Guide
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The Uninstall Wizard appears. The uninstall procedure is completed following a
confirmation request.
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Installing Third Party Software for

Server-side Monitoring

Installing SNMP

Simple Network Management Protocol (SNMP) enables communication between
systems in your load session. If SNMP service is installed on your system, it runs
automatically in the background.

Installing SNMP Service on a Windows 2000 Platform

To install SNMP service on Windows 2000:

1. Select Start » Settings » Control Panel » Add/Remove Programs.

The Add/Remove Programs dialog box appears.

2. Click Add/Remove Windows Components.

The Windows Components Wizard dialog box appears.

3. Click the Management and Monitoring Tools check box and click Next.

Windows asks for the location of the Windows installation files.

4. Specify the location of the Windows installation files and click OK.
SNMP service is installed.

WEBLOAD? Installation Guide
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Installing SNMP for WebLogic

The WebLogic SNMP agent will not work as a subagent for the OS master agent. The
workaround is to make WebLogic act as master (on port 161) and delegate to the native
OS agent.

To install SNMP for Weblogic:

1. Modify the winnt\system32\drivers\etc\services file from:

snmp 161/udp

to:

snmp 1161/udp (any free port will do here)

2. Modity the startsnmpagent.cmd file in the WebLogic root. For example:

%JAVA% weblogic.SNMPAgent -password mypassword -serverURLs
t3://1ocalhost:7001 -snmpPort 161 -trapDestinations
localhost:162 -otherAgents 1161:.1.3.6.1.2.1.

The -snmpPort 161 flag makes WebLogic the master agent.

The -otherAgents 1161:.1.3.6.1.2.1. flag tells this agent to delegate the
1.3.6.1.2.1 subtree to port 1161 (where the native agent is running).

3. Run this file and ensure the agent is restarted on the 1161 port.

4. Use system command netstat -a -n -p udp to view the active udp ports.
Both udp 161 and udp 1161 should appear in the resulting list. The WebLogic

appserver should be running.

For more information see:
http://www.weblogic.com/docs51/admindocs/snmpagent.htmlfuse agent

* 30 Chapter 7. Installing Third Party Software for Server-side Monitoring
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Installing SNMP for ORACLE

The ORACLE SNMP agent will not work as a subagent for the OS master agent. The
workaround is to make ORACLE act as master (on port 161) and delegate to the native
OS agent.

To install SNMP for ORACLE:

1. Modify winnt\system32\drivers\etc\services file from:

snmp 161/udp

to:

snmp 1161/udp (any free port will do here)

2. On the ORACLE machine perform following steps:

a. Modify the oracle\ora8l\network\admin\encaps.cTg file by adding
the following line:

AGENT AT PORT 1161 WITH COMMUNITY PUBLIC

b. Modify the oracle\ora8l\network\admin\master.cfq file, specifying
that ORACLE runs on port 161.

c. Start following services:

OracleSNMPPeerMasterAgent

OraclePeerEncapsulator

Setting Up JMX for Application Server Monitoring

You can use JMX to monitor several application servers in the Performance
Measurements Manager. Some of these application servers require that you install its
specific JMX client software.

Setting Up JMX Client for WebSphere

To monitor the WebSphere-6.1 application server in the Performance Measurements
Manager, you must install the JMX client for the WebSphere-6.1 application server.
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To set up the JMX Client for WebSphere:

1. Browse to the WebSphere application server’s installation directory.

2. Copy the following libraries to <WebLOAD directory>\extensions\java:
e com.ibm.ws.admin.client_6.1.0.jar
e com.ibm.ws.runtime_6.1.0.jar
e ibmorb.jar

Now you can monitor the WebSphere-6.1 application server from the PMM.

Setting Up the JMX Client for JBoss

To monitor the JBoss-4.0.4GA application server in the Performance Measurements
Manager, you must install the JMX client for the JBoss-4.0.4GA application server.

To set up the JMX Client for JBoss:

1. Browse to the JBoss application server’s installation directory.

2. Copy the following libraries to <WebLOAD directory>\extensions\java:
e jboss-management. jar
e jbossall-client.jar

Now you can monitor the JBoss application server from the PMM.

Setting Up JMX Client for Tomcat

To monitor the Tomcat-6.0.1 application server in the Performance Measurements
Manager, you must install the JMX client for the Tomcat-6.0.1 application server.

To set up the JMX Client for Tomcat:

1. Browse to the Tomcat application server’s installation directory.

2. Open the server start script, such as the %TOMCAT_HOME%\bin\catal ina.bat
file.
3. Append the following lines to the script:

set CATALINA OPTS=%CATALINA OPTS% -
Dcom.sun.management. jmxremote

set CATALINA_OPTS=%CATALINA_OPTS% -
Dcom.sun.management. jmxremote.port=3030

e 32 e
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Note: The remote port number must be set to 3030, to work with WebLOAD's user
interface.

set CATALINA_OPTS=%CATALINA_OPTS% -
Dcom.sun.management. jmxremote.ssl=false

set CATALINA_OPTS=%CATALINA_OPTS% -
Dcom.sun.management. jmxremote.authenticate=false

Setting Up JMX Client for WebLogic

To monitor the WebLogic-9.0 or WebLogic-10.0 application server in the Performance
Measurements Manager, you must install the JMX client for the WebLogic-9.0 or
WebLogic-10.0 application server.

To set up the JMX Client for WebLogic:

1. Browse to the WebLogic application server’s installation directory.
2. Open the server start script, such as the startWebLogic.cmd file.

3. Append the following lines to the script:

set JAVA_OPTIONS=%JAVA_OPTIONS% -
Dcom.sun.management. ymxremote

set JAVA_OPTIONS=%JAVA_OPTIONS% -
Dcom.sun._management. jmxremote . port=10010

Note: The remote port number must be set to 10010, to work with WebLOAD’s
user interface.

set JAVA_OPTIONS=%JAVA_OPTIONS% -
Dcom.sun.management. jmxremote.ssl=false

set JAVA_OPTIONS=%JAVA_OPTIONS% -
Dcom.sun.management. jmxremote.authenticate=false

Installing WAS for WebSphere

To monitor the IBM WebSphere 5 application server in the Performance Measurements
Manager Wizard, you need to install the IBM WebSphere Application Server WAS,
Version 5 Application Client software.

For information about obtaining and installing the WebSphere 5 Application Client
software, refer to the WebSphere info center at
http://www.ibm.com/software/webservers/appserv/infocenter.html or contact IBM.
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When this software package is not installed, or not installed properly, monitoring of
WebSphere 5 using WAS is not available and WebLOAD might show one of the
following error messages:

* The IBM J2EE Client version x (required for probing WebSphere) is not installed.
Please install the IBM J2EE Client.

* The IBM J2EE Client version x (required for probing WebSphere) is not installed
properly. Please reinstall the IBM J2EE Client.

* The Java program associated with the IBM J2EE Client (required for probing
WebSphere) is not found. Please reinstall the IBM J2EE Client.

* The IBM J2EE Client version x (required for probing WebSphere) is not installed.
Before continuing, please install the IBM J2EE Client.

* The file [name], essential for probing WebSphere, could not be found in the J2EE
directory. Before continuing, please install the IBM J2EE Client version x.
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